WatchUSeek Watch Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,477 Posts
Discussion Starter #1
Hi all, well i trust every one had a good xmas.

I have noticed a small problem with the PO, i set it against my breitling B1, and noticed that it has lost 2.5 mins a day, is this normal, or is it still settling down as its not that old.

Has anyone else heard of any problems with the PO's.
 

·
Registered
Joined
·
704 Posts
That seems way excessive to me, have you made sure the watch is fully wound with a full spring tension prior to the comparison test? How old is the watch?
 

·
Registered
Joined
·
13,407 Posts
Never owned a PO but dozens of other watches and not even a crummy pos Seiko BM kept time that poorly.
That watch is screwed up IMO.
 

·
Registered
Joined
·
7,101 Posts
Make sure the watch is fully wound. Set it exactly down to the second and wear it for a day.
2.5 mins is exessive. Perhaps you should get it looked at while it is still under warranty. Just to be sure.

teeritz
 

·
Registered
Joined
·
4,002 Posts
Lou, I have a friend with 2 POs. He reports incredible accuracy. Hope it settles down for you.
 

·
Registered
Joined
·
2,477 Posts
Discussion Starter #6
Thanks guys, well i have had it on for the last 48hrs and all seems fine, it may have been that it wasnt on the winder and the power reserve was low, possibly a bit paranoid on my part, but i will see.

I have faith in the brand as my AD swears by them and even got on his knees ( well almost) to beg for me to buy one, instead of my 8th breitling. Apart from this little hicup, all is well, and i found myself a 8 month old speedy pro for a good price but sadly the warrenty and cards etc were destroyed in a fire. So in other words watch this space..
 
1 - 6 of 6 Posts
Top