WatchUSeek Watch Forums banner

1 - 20 of 60 Posts

·
Registered
Joined
·
1,108 Posts
Discussion Starter #1
Ladies and Gents I'm starting this thread as a place for Android 9 users to report issues with the G-Shock connected app.
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter #2 (Edited)
Connection issues I'm experiencing on Pixel 3 Android 9:

Initial pairing of watch and app works perfect (including point memory and auto sync) whether app is running in background, phone is locked, or app is in focus on screen. However, if phone reboots or if Bluetooth is toggled off and then back on, the watch only auto syncs or makes a point memory connection when the app is actively in focus on the screen. Auto syncs and point memory attempts all fail with app running in background or if phone is locked. Only repair is to remove pairing information from both app and watch, then pair again. Problem then recurs if either of the aforementioned triggering events occur.

Please report to Casio if you're experiencing similar. I chatted with tech support and they were completely unaware: https://www.casio.com/support/watches

Most earlier versions of Android are not having this problem so Casio should be made aware by the few of us who have Android 9. As more Android users upgrade to 9, the problem will become more widespread so let's try to get it fixed by reporting. Thanks.
 

·
Registered
Joined
·
527 Posts
My watch has synched once. I have tried to connect it through bluetooth again and it wont synch. It doesn't seem to be synching up with the atomic clock either.

Sent from my SM-N910T using Tapatalk
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter #4
Thanks Thomas please report to Casio support link above

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
101 Posts
Connection issues I'm experiencing on Pixel 3 Android 9:

Initial pairing of watch and app works perfect (including point memory and auto sync) whether app is running in background, phone is locked, or app is in focus on screen. However, if phone reboots or if Bluetooth is toggled off and then back on, the watch only auto syncs or makes a point memory connection when the app is actively in focus on the screen. Auto syncs and point memory attempts all fail with app running in background or if phone is locked. Only repair is to remove pairing information from both app and watch, then pair again. Problem then recurs if either of the aforementioned triggering events occur.

Please report to Casio if you're experiencing similar. I chatted with tech support and they were completely unaware: https://www.casio.com/support/watches

Most earlier versions of Android are not having this problem so Casio should be made aware by the few of us who have Android 9. As more Android users upgrade to 9, the problem will become more widespread so let's try to get it fixed by reporting. Thanks.
I truly appreciate
 

·
Registered
Joined
·
2,149 Posts
My iOS/Android 9 test is complete, (watch and device were within 1 metre of each other during each sync test.)

For those of you with an interest, screen shots of the tests are shown in THIS THREAD

Result as follows:

Apple iOS: 27 out of 28 successful syncs (96.4%)
Android 9: 24 out of 28 successful syncs (85.7%)
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter #8
Ken I'm sorry if I asked before, but did you attempt an app in background or phone locked sync after either (1) toggling bluetooth off then on or (2) power cycling the phone?
 

·
Registered
Joined
·
2,149 Posts
Ken I'm sorry if I asked before, but did you attempt an app in background or phone locked sync after either (1) toggling bluetooth off then on or (2) power cycling the phone?
Hi tomchicago. No need to apologise. Yes I did toggle bluetooth off then on then powercycling the phone/device. That’s when I discovered that recycling the power left the app running in the background on both operating systems.
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter #10
So I am on the road and paired my 5000 with my Pixel 3. Battery optimization switched off for the app. Sure enough it failed to point memory and auto sync after phone power cycle. So fickle! Can anyone else confirm this on Android 9? Thanks.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
2,149 Posts
So I am on the road and paired my 5000 with my Pixel 3. Battery optimization switched off for the app. Sure enough it failed to point memory and auto sync after phone power cycle. So fickle! Can anyone else confirm this on Android 9? Thanks.

Sent from my Pixel 3 XL using Tapatalk
Hi tomchicago, I’m attempting to replicate our issue. So far I have:

deleted the app from my iPad,
re-installed same on my Google Pixel 2 XL,
reset the watch to factory settings and
paired the watch to the phone.
battery optimisation turned off for the app.

I have now toggled bluetooth off:

AF3C944D-C61A-4A26-84D5-80298ED2A900.jpeg

Turned it back on:

B46E46BF-42DF-4A77-9984-385ACC4AF9B6.jpeg

Restarted the phone:

FDC94BBB-0D5D-4CD5-9630-A5CA34D7C518.jpeg

Interestingly after the restart, the apps are still running
 

·
Registered
Joined
·
2,149 Posts
UPDATE from above post:

After expected time sync:

687AF7A6-334C-47D1-BA1C-3E9B98E8421F.jpeg

No sync occurred

6B0D1A62-906A-4B6F-BDEB-6D2F130CCE5E.jpeg

After Point memory attempt:

EEFE6B3A-2AF9-42FA-B6F1-5F9EBDFB1AB5.jpeg



6DFEA527-3D90-4A6E-8FB1-C246A4CDF2A7.jpeg


But no Time sync showing

032AABC7-9799-4C11-8EAE-52C0F108CF3D.jpeg


Hope this helps! Its confused the heck out of me though!
 
  • Like
Reactions: Servus

·
Registered
Joined
·
388 Posts
Had to update to Android 9.

My findings as below.

1) Phone resetted after Android 9 update. No sync was working even though showed app was running in background. Watch wont connect/auto sync to app without re-pairing.

2) 3D maps wasnt working on Android 8. Now it works. No idea why/how.

3) Toggle bluetooth off/on. App shows still running in background. Auto sync works.



Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
4,284 Posts
Auto syncing still isn't working for me with Note 9 + Android 9. Did you need to remove and re-pair the watch, or any other tricks?
Uninstall the app deleting cache, install.. and add devices again
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter #18
Uninstall the app deleting cache, install.. and add devices again
It's pathetic that this has to be done every time the phone is power cycled. Please report it to Casio support else it will neve get fixed.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
388 Posts
Report done.

Dont think this inconvenience will affect me much as I dont power cycle the phone on regular basis. It will definitely help not having this issue as it will be a set and forget settings.

Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
1,427 Posts
Uninstall the app deleting cache, install.. and add devices again
That trick didn't work for me. I'm close to Colorado and the radio-based sync works most nights, so this isn't really a big deal. But Casio still needs to release an updated version of the app that fixes this issue.
 
1 - 20 of 60 Posts
Top