WatchUSeek Watch Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there!
After finding my old PRT-500 in a drawer I took it to a shop to replace the battery.
They messed it up, the watch displayed "open" the whole time and the light was on the whole time...
returning home I did some searching in the internet and found some solutions - here in the forums ;)
right now I reassembled the watch and it seems to work properly, but I still have 1 of 4 springs left over???!:-s

Where to put it?
I have put 1 spring [a small one] to make the contact with the speaker, and 2 springs [a little bigger] to attach to the contact in the back that is responsible for displaying the "open" massage.
After resetting it [AC-shortening] everything works fine but one spring [a small one] is still waiting to be attached somewhere - but I can't find out in which hole to put it?

Any advice is greatly appreciated!:roll:

[and sorry for my not so perfect english...]
Greetings from Germany!
Torsten
 

·
Registered
Joined
·
922 Posts
Well, if all functions work fine, I'd leave it be. Keep the extra spring safe, but no since opening it up again and doing more harm than good. That's what I'd do.

Mike.

And welcome to the forum!!
 

·
Registered
Joined
·
374 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #4

·
Registered
Joined
·
3 Posts
Discussion Starter #5
And for everybody who runs into the same problem:
I think the 4th spring is a spare spring that is stored in one of the holes in the watchcase!
 
1 - 5 of 5 Posts
Top