WatchUSeek Watch Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
486 Posts
Discussion Starter #1
hey everyone, i just bought my third Solar Frogman a couple days ago, GW-200TC, it was a display model at a local mall, so it was under full flourescent light for probably 10 hours a day for i dont know how long. I got it home, left it in the box for 2 days, took it out this evening to play with it, and noticed that the display light doesnt work, not when you press the light button, nor in the auto EL mode.:-s There are still three bars showing on the display, so i am assuming its at full charge still...every other function works fineo| ...my other two new Frogmen have lights that work properly with both the light button and auto EL....any ideas, or should i go get my money back?...i'd really rather not have to send a brand new watch in for service, even if its covered under warranty:-(
 

·
Registered
Joined
·
8,522 Posts
well, I am not a froggie expert, since those models doesn't do anything to me. but on the other hand all g-shock's with el-backlight should work very similar.

with three bars showing on the battery charger I would presume your watch has a defective el-function. if you have the chance to give it back and exchange, I would do so.



regards, holger
 

·
Moderator G-Shock Forum
Joined
·
21,587 Posts
Hi pdxgti8v,

Does there something happen in the display when you push the button. Isn't there the text Recovery blinking? It should be under the time digits a bit in the middle (see dusty picture)



If so you might have a defective battery, which happens very rarely on this model number. If not, maybe the contact spring in the back doesn't make appropriate contact.

Cheers,

Sjors
 

·
Registered
Joined
·
6,195 Posts
The El light works by high voltage going trough the EL panel causing it to vibrate and generate light as a result of some chemistry. Exactly how this chemistry work I do not know. But anyhow in order for this chemical process which generates excited electrons(light) to work it needs access to high Voltage about 200 Volts which is almost as much as from an electrical socket in Europe (235 Volts). For this to happen the much lower Voltage from the battery needs to be up converted to 200 Volts. This is done trough a tiny converter/transformer that can convert the power for a few seconds.

Try this:

-In a really quiet room take the watch to your ears and push the light button. Can you hear it buzzing? there shoudl be a faint buzzing coming from the watch. If so it means that the converter is working and generates power but maybe not enough.

If so the next fault might be the battery that simply cannot generate enough output required for this short burst of high drainage. Since the watch is new and was stored in bright conditions it is most likely a faulty cell.

The least probable cause might simply be a faulty EL panel but it is still a possibility.

Anyway any of these causes requires you to hand it in for service. It shoudl only be serviced by qualified casio service perosnal. In Sweden this is not a problem since most watch sellers here have the proper education but this is not the case in most places abroad so it has to be sent somewhere.

But it is under warranty I presume!
 

·
Registered
Joined
·
486 Posts
Discussion Starter #6
Hey everyone, thanks for all the responses! No Sjors, the watch wasnt in recovery mode, i double checked that after reading your post, and Joakim, I checked to see if i could hear the watch buzz when i was pressing the light button, and i couldnt hear any buzz at all....so in the end, after considering the cost of returning the watch to southern california, which is where the closest authorized service center is, i decided to listen to Holger and just return the watch to where i bought it. It broke my heart to take it back, but as I said, even though it would have been fixed under warranty, i just didnt want to hassle with mailing it...it wasnt like it was a rare frogman to begin with, so its not so bad. I have 2 new frogman's still, each less than 2 weeks old, and i havent even worn one of them yet (the green band one). I am currently designating my blue band TC as the daily wear watch, and i am happy with them....now, I think i'll spend that money on either a Giez or an MTG910:-! thanks for all your support, guys|>
 

·
Registered
Joined
·
6,269 Posts
This is silly, but the EL won't illuminate, for solar models, unless it's dark enough in the room.

Just my $0.02.

Neil
 

·
Registered
Joined
·
486 Posts
Discussion Starter #9
This is silly, but the EL won't illuminate, for solar models, unless it's dark enough in the room.

Just my $0.02.

Neil
hey neil,

:-d yes, i made sure it was in darkness or dim light when i tried the lumination....in the same light in my room, both of my other frogman's lit up both in auto and by pressing the button...the froggie i returned wouldnt light up in either mode during the same conditions...but yes, that was a good point:)

thanks
brad
 

·
Registered
Joined
·
1,020 Posts
"This is silly, but the EL won't illuminate, for solar models, unless it's dark enough in the room."

My GW-200TC and 2300 will light if I press the light button regardless of lighting conditions in the room. Light in the room only affects the auto-EL function.
 

·
Registered
Joined
·
351 Posts
gee whiz, I wonder if I did not end up with this exact 200TC. I recently picked one up on ebay and I am having problems with the EL. The problem was disclosed in the listing and I got it for a great price so no complaints. But I would still like to see if I can get the EL to work. Here are some pertinent details, maybe I can get some help here.

-If I go into a pitch dark room and put my eye up to the watch it does light up or function when I push the button. But it is VERY DIM. I wonder if there is some sort of....accelerator/magnifier/random part that is defective or out of spec that would cause it to not light up completely.

-It is fully charged

-The back has been off. The previous owner told me he did open it to check to make sure it had the proper battery. But, it had been opened and messed with before he owned it. So it looks like someone had possibly tried to fix it before. Or maybe it was not put back together properly. Is there a spring or a tab that needs to be making contact?

-The AUTO EL does function, but still at the very dim level.

Thanks in advance for your input!!


hey everyone, i just bought my third Solar Frogman a couple days ago, GW-200TC, it was a display model at a local mall, so it was under full flourescent light for probably 10 hours a day for i dont know how long. I got it home, left it in the box for 2 days, took it out this evening to play with it, and noticed that the display light doesnt work, not when you press the light button, nor in the auto EL mode.:-s There are still three bars showing on the display, so i am assuming its at full charge still...every other function works fineo| ...my other two new Frogmen have lights that work properly with both the light button and auto EL....any ideas, or should i go get my money back?...i'd really rather not have to send a brand new watch in for service, even if its covered under warranty:-(
 
1 - 11 of 11 Posts
Top