WatchUSeek Watch Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hi everybody, first post here.

I have an atomic solar GW 1200A that is several years old, 2004 i think.

After several months of non use i put it back in the rotation; why i took it out i don't know. I took it out and let it recharge fully in the sun, per manual recommendations and it was running fine but i noticed the analog hands had come out of sync with the digital (correct) time.

When I went to the menu to manually set the hands to match the digital, the watch seized up and wouldn't let me adjust the hands and the RECOVER light started blinking. I know its supposed to do this if the CPU or whatever becomes overtasked. I made sure everything like the light, alarm, hourly chime and such were disabled and tried again with the same result. It's done this several times and always returns to the correct digital time when the recover is complete but obviously the hands are still incorrect.

Anyone else have this with a similar model? Should i find the local rep and ask them?

I tried looking for a search option within the forum but couldn't find one. If there is a thread for this already I'd appreciate the link.

thanks
 

·
Registered
Joined
·
1,555 Posts
Sounds like a problem a lot of the people here have had - a dead rechargeable battery. Try searching for 'dead battery' and 'CTL1616' (I think that's the common battery model that fails).
 

·
Registered
Joined
·
4,076 Posts
Yep. Sounds like the rechargeable battery is dead. If the watch was left in darkness for a prolonged period of time, the battery may have been damaged. Rechargeable batteries don't like being stored without a charge.
 
1 - 3 of 3 Posts
Top