WatchUSeek Watch Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
Just a Just a curiosity, I bought a gshock off of ebay on a whim,model g7510, The adjust button is stuck in which I believe is just misaligned because someone took the module out It's not in bad shape, needs cleaning, original bezel and strap for it is available, the only other watch was in the U.K. .Does anyone have/ had this model before and how did they like it? Any quirks, thanks in advance
 

Attachments

·
Registered
Joined
·
500 Posts
I've never owned one, but they look cool... I say go for it. Maybe try and seeing if you can free the button up before you spring for the replacement resin, but I bet it will be a great watch when you are done with it.
 

·
Registered
Joined
·
1,271 Posts
any Gshock is worth restoring
it it works out, you have a classic Gshock
if it doesnot work out, you have gained some experiences
did you search for the manual and read? after bought it on a whim?
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #8 ·
Thanks for the input, and you are all right, it is a classic and some parts are still available, plus it will give me something to do. My health has declined and became officially disabled in Dec. At 55(used to do security in a haunted power plant built in 1948), im a type 2 diabetic with congestive heart failure, lymphodema complicated by cellulitis and neuropathy.My twin died in Feb. of this year, cancer, our dad had it, our uncle did, I have it, found out July 4th last year when I was diagnosed with a 23mn kidney stone(25 being 1 inch), still there. Until they release the cure for all that, which they have, I'm not taking a covid shot. I may ask about restore techniques in the future from ya'll.
 

·
Registered
Joined
·
5,877 Posts
Go for it.

probably somebody changed the battery and the module came out and the person did not bother to align it or there is a lot of crud under the button.

I would take the bezel off and give it a soapy water clean. While the bezel is off, see if the button works. If not then it is ether stuck due to crud or not lined up in the case. If it works then the bezel swelled a bit around the button. I take a bit of fine sand paper and twist it around in the hole and see if you can lightly shave the hole a bit to allow the button to move. That would fix the issue but not change the look of the bezel

I had one and it was a very nice looking watch, the vibe alarm gave off a good vibration (you knew when that watch's alarm went off)
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #12 ·
Go for it.

probably somebody changed the battery and the module came out and the person did not bother to align it or there is a lot of crud under the button.

I would take the bezel off and give it a soapy water clean. While the bezel is off, see if the button works. If not then it is ether stuck due to crud or not lined up in the case. If it works then the bezel swelled a bit around the button. I take a bit of fine sand paper and twist it around in the hole and see if you can lightly shave the hole a bit to allow the button to move. That would fix the issue but not change the look of the bezel

I had one and it was a very nice looking watch, the vibe alarm gave off a good vibration (you knew when that watch's alarm went off)
[/QUOTE. I think it's not aligned since I was told all other functions work and it's not blinking to adjust anything. In the pics I can see different seconds in 2 different pics. Thanks for the sanding tip, never thought of that. If it's built like my ae1200 then I can remove the insert with the info on it and use a sharpie if need be to re-black any worn sections. And I may, if needed, use a permanent sharpie in light grey or silver to give the aluminum bezel a uniform look.
 

·
Registered
Zelos Mako V3 bronze frost || Casio PRW-7000X || Casio Gulfman GW-9100 || Victorinox INOX Mechanical
Joined
·
538 Posts
I couldn't see your replies and now i know why, go to the "..." On the top of yours posts and "Edit" then go to the "/quote" and put "]" between the "quote" and your message reply
 
1 - 13 of 13 Posts
Top