WatchUSeek Watch Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter · #1 ·
Hi all,

I've just received a rather nice radio room this morning from Meranom and having would and set the time, I noticed the second hand kept stopping around the 30 second or so mark every minute. Also, when setting the hands the second hand flies all over the place and needs tapping to restart. A quick gentle shake and it all gets moving again. My original thought was it as faulty and needed returning, but I decided to put it on and see how it goes. Well after wearing, and no doubt shaking as I walk, the second hand seems to now be working fine without stopping. Could it just be that it was a little tight as new or the oil a little thick?

Any one else seen this? I've bought two others and they seemed fine.

Regards,
Steve
 

·
Registered
Joined
·
3,294 Posts
Hi all,

I've just received a rather nice radio room this morning from Meranom and having would and set the time, I noticed the second hand kept stopping around the 30 second or so mark every minute. Also, when setting the hands the second hand flies all over the place and needs tapping to restart. A quick gentle shake and it all gets moving again. My original thought was it as faulty and needed returning, but I decided to put it on and see how it goes. Well after wearing, and no doubt shaking as I walk, the second hand seems to now be working fine without stopping. Could it just be that it was a little tight as new or the oil a little thick?

Any one else seen this? I've bought two others and they seemed fine.

Regards,
Steve
Hi Steve,

I have a Vostok with a seconds had which seems to move violently from in the direction you happen to be winding, however, once it is going, it runs fine and keeps perfect time. I have another which needs a bit of a tap on the back to get it going, and then it is fine. Yours seems to have both in one, but if once you get it going and it’s running well and keeping good time, if anything like my two, you’ll be ok.

 

·
Registered
Joined
·
206 Posts
Hi Steve,

I have a Vostok with a seconds had which seems to move violently from in the direction you happen to be winding, however, once it is going, it runs fine and keeps perfect time. I have another which needs a bit of a tap on the back to get it going, and then it is fine. Yours seems to have both in one, but if once you get it going and it’s running well and keeping good time, if anything like my two, you’ll be ok.
The strange thing is that it rush to +45 min and stays there :)
I am not giving up of my Amphibian I'll find a way :)
 
1 - 4 of 4 Posts
Top