WatchUSeek Watch Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
520 Posts
Discussion Starter · #1 ·
My PO had been running pretty consistent at about -2 per day..But Ive noticed over the last month or so that my watch has been running slow. When I reset the date this month I was about 3 minutes slow.. I tried testing it off of the us time site the past few days and it seems like its about -5 to -6 per day.. So a few things..

1. Any cause for alarm? I personally am not anal about the time and I can live with -5 or so, but any more than that and its going be a problem.
2. I know that there is that Kello app for iphones, but I have a droid, does anyone know of any droid apps that can check your watches time and regulation? And or do they work?..
If your watch started running at -6 per day what would you do?

My PO is 4 years old, I bough it pre owned 2 years ago. Well as far as the date on the card it is 4 years old, I guess it could have been dated after the original purchase....
Thanks in advance for any input..
 

·
Registered
Joined
·
10,562 Posts
If it bothers youthen just send it to be tested on a timing machine. This should tell the watchguy if anything is wrong. But before trying this let your watch run down then wind it back up and test again.
 

·
Registered
Joined
·
660 Posts
I would give it a full wind (80 "sweeps" with thumb and forefinger) every 4-5 days to see if it makes a difference. Otherwise I would not worry about it since you probably will get it serviced in another 2 years or so. If you know somebody that you trust that has in fact worked on coaxial movements before, you could send it in for a regulation. But before I did that I would keep track of its rate every day for 2-3 weeks, making sure it was fully wound to see exactly how many seconds it needs to be sped up.
 

·
Registered
Joined
·
520 Posts
Discussion Starter · #4 ·
Thanks for the info so far.. No I don really have anywhere I can sent it for testing nor do I know anyone who works on watches. When I changed the date this month and re set the time I did wind it to see if it was run down, but it seemed that it was fully wound. I guess the first thing ill try is to let it run down untill it stops nd then fully wind it and check it..
 
1 - 4 of 4 Posts
Top